Welcome to the O2 Community

Has your question already been answered? See the community FAQ's

Apple

Reply
Anonymous
Posts: 0
Accepted Solution

Wifi calling

Hi. I'm on latest version of IOS 10.3.2 (iPhone SE) & O2 28.4 - enabled wifi / 4g calling with O2 but can't enable on my iPhone - I'm on sim only but my partner has same phone supplied by O2 and same issue - how do I resolve?
Posts: 88,640
Topics: 536
Solutions: 11,503
Registered: ‎04-04-2012

Re: Wifi calling

How do I set up Wifi and 4G Calling – iPhone 7, 6s or SE

First you will have to check that Wifi and 4G Calling has been added to your account. For personal tariff customers – Sign in to My O2, Business customers – Contact Business customer services, your Digital Advisor or Business Partner. Once your new services are added to your account, follow the instructions below to enable Wifi and 4G Calling.

 

  1. To enable Wifi Calling, go to Settings > Phone > Wi-Fi Calling. Make sure Wi-Fi Calling is set to On. To switch off Wifi Calling, set the toggle to Off.
  2. To switch on 4G Calling, go to Settings > Mobile Data > Mobile Data Options > Enable 4G and then Voice & Data to enable 4G Calling. To switch off 4G Calling, select ‘Data’.

 

If you don’t see a Wifi Calling or 4G Calling menu option, you may have to update to the latest iPhone software:

  • Go to Settings > General > Software Update. Install an update if available (you’ll need iOS 10.3 or above)
  • Once installed go to Settings > General > About. The ‘Carrier’ value on this screen should be set to 28.3 or above. If this hasn’t updated automatically, you should get a message from us to update to new carrier settings. Accept by pressing ‘Update’.
  • Follow the instructions above to enable Wifi and 4G Calling

 

Please note: This set-up process may re-start your device so if you would like to receive these instructions by email please click here and we will send them over.

 

It can take 24 hours from request to see it enabled and rebooting the phone sometimes helps.

http://www.o2.co.uk/business/support/network-support/wifi-and-4g-calling#iphonevideo

 

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone7 (EE)
Anonymous
Posts: 0

Re: Wifi calling

Already tried this - If I try & switch on wifi calling via settings on phone just get message to allow wifi calling on this account contact O2. I have checked that it is enabled via My O2 & restarted phone / left for more than 24hrs
Posts: 88,640
Topics: 536
Solutions: 11,503
Registered: ‎04-04-2012

Re: Wifi calling

Sounds like you need to call customer service on 202.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone7 (EE)
Anonymous
Posts: 0

Re: Wifi calling

I managed to resolve by removing wifi/4g calling via My O2 & readding - you need to wait for it to be removed before you can readd - however this solution appears hit & miss - it didn't work for someone else
Anonymous
Posts: 0

Re: Wifi calling

Worked for other person after removing / reading twice
Highlighted
Posts: 88,640
Topics: 536
Solutions: 11,503
Registered: ‎04-04-2012

Re: Wifi calling

Good to know, thanks.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone7 (EE)