Welcome to the O2 Community

Has your question already been answered? See the community FAQ's

Apple

Reply
Anonymous
Posts: 0

Re: New iPhone 6 - random "No Service"

@GeorgeStark The simswap takes a wee while to activate if you do it yourself. I got the lad in the O2 shop to do mine and it sorted itself out almost instantly but my mum did hers herself and it took a while to come into play. Give it a wee bit of time and if no change, head into the Apple store. Might be worth phoning Apple first so see if it's anything you can sort yourself before making the trek. Good luck!

Level 3: Thinker
Posts: 71
Registered: ‎26-09-2008

Re: New iPhone 6 - random "No Service"

Sorry, I should have been clearer. My SIM swap took about 8hrs but I did it several weeks ago and I still see this random "No Service" every so often.
Anonymous
Posts: 0

Re: New iPhone 6 - random "No Service"

Ah, I see. If the service still drops, I would definitely suggest going into the Apple store for sure, then.

Level 3: Thinker
Posts: 71
Registered: ‎26-09-2008

Re: New iPhone 6 - random "No Service"

I'll see how often it keeps happening...if it's only as frequent as it is now, I may just put up with putting it into Airplane mode and back out again.  It's a First World problem, at the end of the day.  Smiley Tongue

Anonymous
Posts: 0

Re: New iPhone 6 - random "No Service"

Yes, it is but if you have a faulty handset it might be worth getting it checked out just in case you are eligable for a replacement.

Posts: 83,875
Topics: 578
Solutions: 4,218
Registered: ‎04-01-2009

Re: New iPhone 6 - random "No Service"

Level 2: Apprentice
Posts: 31
Registered: ‎18-09-2012

Re: New iPhone 6 - random "No Service"

@GeorgeStark 

 

Similar to you, I also have had 'No Service' intermittently on my iPhone 6. It doesn't appear often, but it does appear. This only appeared around where I live, but didn't think it was due to signal because my previous iPhone 5 and my Wife's iPhone 5 were fine.

 

I phoned Applecare to see if they knew what was causing it, but after running through the standard troubleshooting (which I had already tried), they just said they would escalate the case to senior engineers.

 

I was convinced it is not hardware fault, so I started properly observing the issue. As mine and my wife's iPhone 5 were fine, I figured the only difference had to be 4G. For me at least, I think the issue is caused by the iPhone trying to switch from 3G to the 4G band. I do get 4G where I live, but the signal is up and down and better outside. It tries to connect, but the signal may be not stable enough for it to latch on properly. Then at other times it does connect. Turning airplane mode on and off will force the phone to pick up the strongest current signal, which is why it comes back.

 

So, since Saturday morning, I have had 4G turned off when at home, and I haven't seen 'No Service' since. I turn my 4G back on when I'm out and about, and it connects fine.

 

Perhaps try turning 4G off when in a weak area. I'm not saying this is what is causing your issue, but it's worth a go.

Level 3: Thinker
Posts: 71
Registered: ‎26-09-2008

Re: New iPhone 6 - random "No Service"

[ Edited ]

@amcleod 

 

I'd say you're right...I've been thinking the very same thing myself (hence, why I'm not really fussed about pursuing it as a hardware issue).

All I can add is that I hardly ever have 4G enabled and I never have it on at home (as I don't live in a 4G enabled area); I've definitely seen it happen when I've had 4G turned off, but I still think it's caused when the handset is trying to find a stronger signal, etc.

It never used to happen with my iPhone 5, but then it only had to be concerned with 2G and 3G...yes, I've just said it happens when 4G is disabled but who actually knows what that toggle does.  It's feasible that the handset will still try and search to enumerate the number of networks available to it, even though it's been told not to connect using 4G.