cancel
Showing results for 
Search instead for 
Did you mean: 

Imessages

TC817
Level 1: Joiner
  • 1 Posts
  • 1 Topics
  • 0 Solutions
Registered:

I have a new iPhone 12 and have transferred my number from EE to O2. iMessages are not being sent from my phone number only my email address 

Message 1 of 3
106 Views
1 ACCEPTED SOLUTION

Accepted Solutions

jonsie
Level 94: Supreme
  • 85248 Posts
  • 591 Topics
  • 4463 Solutions
Registered:

A couple of things to check

Settings>>Phone>>My Number

Also check with customer service that you have iData enabled on your account

View solution in original post

Message 2 of 3
104 Views
2 REPLIES 2

jonsie
Level 94: Supreme
  • 85248 Posts
  • 591 Topics
  • 4463 Solutions
Registered:

A couple of things to check

Settings>>Phone>>My Number

Also check with customer service that you have iData enabled on your account

View solution in original post

Message 2 of 3
105 Views

MI5
Level 94: Supreme
  • 120683 Posts
  • 605 Topics
  • 18164 Solutions
Registered:

@TC817 

Settings >Messages >Send and receive, then tick "start conversations from" your phone number.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 3 of 3
99 Views