cancel
Showing results for 
Search instead for 
Did you mean: 

unable to send o2 email on phone with Wifi switched on

Anonymous
Not applicable

Hi,

I am on o2 broadband and use o2 email. I am unable to send outgoing email from my phone (Sony Xperia SP) when Wifi is switched on (the error message is "email not sent" - very descriptive!); with wifi off everything works fine. I can also send email successfully from a gmail account on my phone, with wifi either on or off. 

 

My wife has exactly the same problem on her HTC V so it is not specific to settings on a single phone. O2 email works perfectly (incoming & outgoing) on laptops & desktop, both by Outlook and webmail.

 

I have been thru the o2 "chat" process with a "guru" who suggested cleaning the SIM card (we had already established that the phone worked fine so not sure what that was intended to achieve!).

All help greatly appreciated,

Thank you

Message 1 of 13
6,177 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Anonymous
Not applicable

Jonty,

I've just tried manual set-up and it seems to work 🙂 It still defaulted to port 587 on manual set-up but I overtyped it to 25 and it accepted it. Just looked at the settings again and it is back to 587 but is still working. I'm going to try the same thing on my wifes phone now.

Thanks for your help, very much appreciated 🙂

Colin

View solution in original post

Message 8 of 13
6,125 Views
12 REPLIES 12

Anonymous
Not applicable

Hi,

 

I don't use O2 email myself but perhaps you could compare the outgoing/SMTP server settings from a working Outlook client with the email app on your phones..?  I wonder if there's a port or other settings that just needs correcting, for example security type, user name or password or the the Requires Sign-in check box.

 

I would assume if you used the browser version of your O2 mail on either phone that it works, i.e. it's just the email app that doesn't work..?

 

Jonty.

Message 2 of 13
6,143 Views

Anonymous
Not applicable

I just attempted to send an email from my laptop through o2 webmail and it failed, I have no idea if the email sent since now the webmail website will not load for me 😕

Can someone from O2 enlighten us please?

Message 3 of 13
6,142 Views

jonsie
Level 94: Supreme
  • 86580 Posts
  • 594 Topics
  • 4987 Solutions
Registered:

Make sure you are using smtp.o2.co.uk as the outgoing server on Port 25. Don't tick security.

 

Strange you are having a PC problem now as it seems to be working fine for me.

Message 4 of 13
6,141 Views

Anonymous
Not applicable

Hi Jonty,

Thanks for the response.The only difference between outlook client and phone settings is the port number - on outlook it is 25, on the phone it is 587. No matter if you over-type the setting on the phone it immediately reverts to 587, i'm not sure why this is.

Otherwise I am using the settings that get created automatically when you set up the account on the phone  - the default is that it doesnt need sign-on. However I have also  tried ticking the "require sign-in" box and putting in user and passwod but this fails when it it tries checks the outgoing server settings - it gives a "failed to connect to smtp.o2.co.uk message".

And yes, it is only the email app that doesnt work, using browser version on phone works fine.

Very frustrating!

Colin

 

 

 

Message 5 of 13
6,137 Views

Anonymous
Not applicable

yes, I'm using smtp.o2.co.uk but cannot use port 25 - if I set it to 25 it keeps reverting to port 587. Is there any way around this?

Thank you

Message 6 of 13
6,133 Views

Anonymous
Not applicable

Hi Colin,

 

I think you're very close, especially with the info above from Jonsie.  I'm wondering... when you created the profile in the email app was the setup automatic or did you press the Manual Setup button..?  When my S2 had an older version of Android running I used to have problems with the email setup but no such issues if I opted for the Manual Setup option.  Perhaps give it a go and see if you're allowed to overtype the settings..?

 

Jonty.

Message 7 of 13
6,131 Views

Anonymous
Not applicable

Jonty,

I've just tried manual set-up and it seems to work 🙂 It still defaulted to port 587 on manual set-up but I overtyped it to 25 and it accepted it. Just looked at the settings again and it is back to 587 but is still working. I'm going to try the same thing on my wifes phone now.

Thanks for your help, very much appreciated 🙂

Colin

View solution in original post

Message 8 of 13
6,126 Views

Anonymous
Not applicable

and now sorted on my wife's phone too - same solution 🙂

Message 9 of 13
6,122 Views

jonsie
Level 94: Supreme
  • 86580 Posts
  • 594 Topics
  • 4987 Solutions
Registered:

Glad it's working for you. Strange but at least it's sorted.

Message 10 of 13
6,117 Views