cancel
Showing results for 
Search instead for 
Did you mean: 

Wifi calling turn on but doesn't seem to work

Nakedtraitor
Level 1: Joiner
  • 2 Posts
  • 1 Topics
  • 0 Solutions
Registered:
Hi, I've recently activated wifi calling using MyO2 and got a 2 years old Samsung A5.
I dial a number normally using the Samsung phone app however get an error message saying 'out of coverage' or 'contact not registered in the network'.
I checked in MyO2 that wifi calling is actuallt turned on.
What could I be doing wrong please?
Message 1 of 15
5,323 Views
14 REPLIES 14

MI5
Level 94: Supreme
  • 119630 Posts
  • 605 Topics
  • 17484 Solutions
Registered:
Your phone isn't compatible.
Only those listed here are
https://www.o2.co.uk/help/network-coverage-and-international/wifi-and-4g-calling#how-do-i-set-up-wif...
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 15
5,294 Views

MI5
Level 94: Supreme
  • 119630 Posts
  • 605 Topics
  • 17484 Solutions
Registered:

https://www.o2.co.uk/help/network-coverage-and-international/wifi-and-4g-calling#15421

wifi calling.PNG

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 3 of 15
5,291 Views

Anonymous
Not applicable
Only the newest high end flagship phones are compatible
Message 4 of 15
5,271 Views

MI5
Level 94: Supreme
  • 119630 Posts
  • 605 Topics
  • 17484 Solutions
Registered:

Just tagging @Nakedtraitor in case they didn't see my reply.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 5 of 15
5,265 Views

Anonymous
Not applicable

While we are on the subject of WiFi calling @MI5 i recently activated mine  through my iPhone & not the myo2 app. It came up straight away on my screen & shows in myo2 as active. That’s another way I’ve found of activating it but i didn’t need to restart my phone after

Message 6 of 15
5,219 Views

MI5
Level 94: Supreme
  • 119630 Posts
  • 605 Topics
  • 17484 Solutions
Registered:
All new contracts with compatible devices have it enabled by default now so all you need to do is turn it on in the phone settings.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 7 of 15
5,217 Views

Anonymous
Not applicable

Cheers for that @MI5

Message 8 of 15
5,212 Views

MI5
Level 94: Supreme
  • 119630 Posts
  • 605 Topics
  • 17484 Solutions
Registered:
No worries mate wink
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 9 of 15
5,204 Views

Nakedtraitor
Level 1: Joiner
  • 2 Posts
  • 1 Topics
  • 0 Solutions
Registered:
Thank you so much for the replies. Looks like I've got a good excuse to change my handset now.
Message 10 of 15
5,197 Views