Welcome to the O2 Community

Has your question already been answered? See the community FAQ's
Reply
Highlighted
Anonymous
Posts: 0

HTC Desire internet settings - WRONG!!!

Those are the settings which the OP incorrectly described as wrong.
I think part of the problem is the awkward way Android deals with packet data settings and the willingness of some people to see a fault without fully understanding the situation.
Highlighted
Anonymous
Posts: 0

HTC Desire internet settings - WRONG!!!

maybe they didn't "test" enough ...

Smiley Very Happy
Highlighted
Anonymous
Posts: 0

HTC Desire internet settings - WRONG!!!

Can someone explain the reasoning for having 2 or 3 different APNs on the phone? Only 1 can be selected at any one time, so surely having the others there makes no difference, as only the selcted APN is actively being used?

I have been trying to get this working on my Desire for the last couple of days, and have come to the conclusion that I can get:
internet and MMS via the O2 Wap APN, but no streaming tv
internet and streaming tv via the O2 Mobile Web APN, but no MMS

I have not tried the Postpay APN.

Also, since I'm on a Simplicity contract with Unlimited Internet Bolt-On, is there a specific APN I have to use to avoid being charged extra for my data?

It's all very confusing, and although one of the reasons I left Vodafone is because they block streaming, there is only one APN needed for everything - none of this messing about...
Highlighted
Anonymous
Posts: 0

HTC Desire internet settings - WRONG!!!

I seem to be in a similar position. I have an HTC Desire which I bought SIM free. I was using it on T-Mobile. I received my Simplicity SIM last week and transferred my number, all of which completed yesterday. Now all I can get is a GPRS data connection and my download rate is 30 kpbs! I was getting almost 2000 kbps on HSDPA with T-Mob!!

In fairness, I knew I wouldn't get HSDPA on O2 but I don't even seem to be getting a reasonable GPRS/EDGE connection. I've been trying different APN settings but so far they all perform the same.

I've emailed customer support, I hope they can sort it, this is rubbish, online services are completely inaccessible now Smiley Sad
Highlighted
Anonymous
Posts: 0

HTC Desire internet settings - WRONG!!!

[ Edited ]
Here is a link that confirms settings

http://mobilereviews.o2.co.uk/devices/d ... =651&tab=8

I have an unbranded desire and i noticed the settings for mms were not correct so thanks to the below guide on mms i can now send and recieve mms messages without any issues,

i only have 2 apn's on my phone which are below, i dont think i actually need a 3rd apn, my phone works fine with all of below settings, i cant seem to actually select multiple apn's to be in use at the same time, on mine i have mobile web as the selected apn, inside the mobile web apn settings at the bottom it shows default, in the o2 mms apn settings at the bottom it states MMS, i think it doesn't matter that you cant select mms apn as it will work when you need to send and recieve an MMS



Settings below - GPRS WAP & MMS

Please note all steps must be completed to ensure the settings are correctly configured.

Please ensure that when entering O2 into the settings that the letter O is selected and not a zero.

When entering the following information do not press Save until told to in the instructions.

Press the Menu key
Tap Settings
Tap Wireless & networks
Tap Mobile networks
Tap Access Point Names
Press the Menu key
Tap New APN
Tap Name then tap the text box and enter O2 Pay Monthly MMS then tap OK
Tap APN then tap the text box and enter wap.o2.co.uk then tap OK
Tap Proxy then tap the text box and enter 193.113.200.195 then tap OK
Tap Port then tap the text box and enter 8080 then tap OK
Tap Username then tap the text box and enter o2wap then tap OK
Tap Password then tap the text box and enter password then tap OK
Skip past Server as this is preset as Not set
Tap MMSC then tap the text box and enter http://mmsc.mms.o2.co.uk:8002 then tap OK
Tap MMS proxy then tap the text box and enter 193.113.200.195 then tap OK
Tap MMS port then tap the text box and enter 8080 then tap OK
Tap MCC then tap the text box and enter 234 then tap OK
Tap MNC then tap the text box and enter 10 then tap OK
Press the Menu key
Tap Save
Tap your new account so a green dot appears next to it
Press the Back key four times to return to the standby screen.

What to do next


Switch your handset off and then back on to complete your settings.

The settings are now complete.

However, if you are still experiencing any issues using this service, please contact O2 Customer Services.

**********************************************************************************

Settings - Mobile Web

Please note all steps must be completed to ensure the settings are correctly configured.

Please ensure that when entering O2 into the settings that the letter O is selected and not a zero.

When entering the following information do not press Save until told to in the instructions.

Press the Menu key
Tap Settings
Tap Wireless & networks
Tap Mobile networks
Tap Access Point Names
Press the Menu key
Tap New APN
Tap Name then tap the text box and enter O2 Mobile Web then tap OK
Tap APN then tap the text box and enter mobile.o2.co.uk then tap OK
Skip past Proxy as this is preset blank
Skip past Port as this is preset blank
Tap Username then tap the text box and enter o2web then tap OK
Tap Password then tap the text box and enter password then tap OK
Skip past Server, MMSC, MMS proxy, MMS port, MMS protocol
Tap MCC then tap the text box and enter 234 then tap OK
Tap MNC then tap the text box and enter 10 then tap OK
Press the Menu key
Tap Save
Press the Back key
Tap the dot next to your new profile to make it the default
Press the Back key four times to return to the standby screen.

What to do next


Switch your handset off and then back on to complete your settings.

The settings are now complete.

However, if you are still experiencing any issues using this service, please contact O2 Customer Services.
Highlighted
Anonymous
Posts: 0

Re: HTC Desire internet settings - WRONG!!!

Hi All. After a little saga I have finally gotten Mobile Internet working on my HTC Desire. It's an unlocked phone from Hong Kong (family got it for me as a present in March) running Android 2.2. I'm with O2 Ireland so this post may not really apply to the UK users in its entirety. But the O2 Ireland website really is a usability disaster. I could barely find the forums and when I did I couldn't find the New Post/Topic buttons. CTRL + F didn't see anything neither. T Also they didn't have manual APN settings like the UK site did. The customer care person acknowledged the "send me the settings" option actually doesn't work for Android phones. Why have it on the site if it doesn't function? The web designer needs a talking to.
Back to the point:
Internet on WiFi worked always from day one. But MMS and Mobile Internet didn't.
I had bought a one month 700mb data plan (called "simplicity" here in Ireland). It was activated according to O2.
I had major problems finding APN settings for Ireland online but got them off Customer Care.
They walked me through the settings. But one thing we found was I couldn't find the "user packet data" check box under Mobile Internet Settings. I looked all over from the Wifi Settings, Bluetooth, other settings. So I felt I as at a lost. I had the APN settings, a tenner worth of mobile data plan activated in my account, so what is it?
I read in the vodafone forums to:
# Go to Wireless & networks # mobile networks # network operators # Search networks # scanning for networks # list of operators will show up # make sure Vodafone.IE star is tick on # Then go to Airplane mode # tick the checkbox to on for few seconds, untick the checkbox, phone will go into short reboots, re-enters your Sim password to kick start your phone to mobile networks. Make sure Data roaming box is untick.

I did this anyway as a leap of faith...
I had tried an app called Tweakker (Android market) earlier and it failed to establish a connection. I tried Tweakker again after my above ideas. Lo and behold it was Successful. Tweakker set up its own APN (I hope this is safe as it probably goes through Tweakker's servers and not O2's- although everything is pretty much blank). If it working, don't fix it!
RESULT: Mobile Internet = CONNECTED. with an E up/down arrow symbol.
Not a very scientific method, but through a user friendly app.
Highlighted
Anonymous
Posts: 0

Re:

[ Edited ]
Here is a link that confirms settings
http://mobilereviews.o2.co.uk/devices/d ... =651&tab=8
I have an unbranded desire and i noticed the settings for mms were not correct so thanks to the below guide on mms i can now send and recieve mms messages without any issues,
i only have 2 apn's on my phone which are below, i dont think i actually need a 3rd apn, my phone works fine with all of below settings, i cant seem to actually select multiple apn's to be in use at the same time, on mine i have mobile web as the selected apn, inside the mobile web apn settings at the bottom it shows default, in the o2 mms apn settings at the bottom it states MMS, i think it doesn't matter that you cant select mms apn as it will work when you need to send and recieve an MMS

Settings below - GPRS WAP & MMS
Please note all steps must be completed to ensure the settings are correctly configured.

Please ensure that when entering O2 into the settings that the letter O is selected and not a zero.
When entering the following information do not press Save until told to in the instructions.
Press the Menu key
Tap Settings
Tap Wireless & networks
Tap Mobile networks
Tap Access Point Names
Press the Menu key
Tap New APN
Tap Name then tap the text box and enter O2 Pay Monthly MMS then tap OK
Tap APN then tap the text box and enter wap.o2.co.uk then tap OK
Tap Proxy then tap the text box and enter 193.113.200.195 then tap OK
Tap Port then tap the text box and enter 8080 then tap OK
Tap Username then tap the text box and enter o2wap then tap OK
Tap Password then tap the text box and enter password then tap OK
Skip past Server as this is preset as Not set
Tap MMSC then tap the text box and enter http://mmsc.mms.o2.co.uk:8002 then tap OK
Tap MMS proxy then tap the text box and enter 193.113.200.195 then tap OK
Tap MMS port then tap the text box and enter 8080 then tap OK
Tap MCC then tap the text box and enter 234 then tap OK
Tap MNC then tap the text box and enter 10 then tap OK
Press the Menu key
Tap Save
Tap your new account so a green dot appears next to it
Press the Back key four times to return to the standby screen.
What to do next

Switch your handset off and then back on to complete your settings.
The settings are now complete.
However, if you are still experiencing any issues using this service, please contact O2 Customer Services.
**********************************************************************************
Settings - Mobile Web
Please note all steps must be completed to ensure the settings are correctly configured.

Please ensure that when entering O2 into the settings that the letter O is selected and not a zero.
When entering the following information do not press Save until told to in the instructions.
Press the Menu key
Tap Settings
Tap Wireless & networks
Tap Mobile networks
Tap Access Point Names
Press the Menu key
Tap New APN
Tap Name then tap the text box and enter O2 Mobile Web then tap OK
Tap APN then tap the text box and enter mobile.o2.co.uk then tap OK
Skip past Proxy as this is preset blank
Skip past Port as this is preset blank
Tap Username then tap the text box and enter o2web then tap OK
Tap Password then tap the text box and enter password then tap OK
Skip past Server, MMSC, MMS proxy, MMS port, MMS protocol
Tap MCC then tap the text box and enter 234 then tap OK
Tap MNC then tap the text box and enter 10 then tap OK
Press the Menu key
Tap Save
Press the Back key
Tap the dot next to your new profile to make it the default
Press the Back key four times to return to the standby screen.
What to do next

Switch your handset off and then back on to complete your settings.
The settings are now complete.
However, if you are still experiencing any issues using this service, please contact O2 Customer Services.


Hi There,
I followed your instructions for the mms and it now works.. however, I cant seem to get rid of the 'E' symbol that pops up at the top in status bar..
anyone know how to fix this? :smileyindifferent:
Thanks