Showing results for 
Search instead for 
Did you mean: 

WiFi calling not working

Level 1: Joiner
  • 2 Posts
  • 1 Topics
  • 0 Solutions

Hi, I have an iPhone 12 under a plan with WiFi calling enabled on the device and super strong WiFi network at home, however, when I test WiFi calling by activating airplane mode and turning the WiFi on and trying to make a call, the phone tells me I have no network connection, which I do because I use my network all day long for data. What could be causing this problem? NB I have WiFi and 4G calling showing as activated on “my O2” also. 

Message 1 of 3

Level 94: Supreme
  • 122242 Posts
  • 609 Topics
  • 18982 Solutions


Sounds like it's not enabled on your account.

You'll need to call customer service.
Numbers here Guide: Coronavirus Community Help and Support 
When it comes to the reason you are calling stay silent for 15 seconds and you will be taken to the keypad options.
Press 2 for Everything Else
Press 5 for More Options
Press 7 for Anything Else which will put you though to someone.
Say "Upgrade", "Lost/Stolen" or "Fraud" if you have to, to get put through to someone.
8.00am is the best time to call if you can.

Also check with them that iData is enabled.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 3

Level 1: Joiner
  • 2 Posts
  • 1 Topics
  • 0 Solutions

Thanks, spoke to O2 and went through their trouble-shooting (basically checking for the obvious). Apparently all iPhones are eligible by default for WiFi-calling so no action needed to my account. The last thing they wanted me to do was take the SIM out and “give it a wipe”, that unsurprisingly did not work either. The phone just seems unable to pass VOIP calls via my network and so they have escalated this to technical support. 

Message 3 of 3