O2 Community

Get help, share tips and chat

Home Broadband & Home Phone

Reply
Level 1: Joiner
Aussie
Posts: 2
Registered: ‎30-04-2008

O2 Wireless box II with VoIP

HI,

New to O2 this week and struggling to get my SIPgate VoIP device working via the O2 Wireless box II.

Grandstream telephone device is connected by wire to port 2 on the box.

I have created a new application to forward the ports for both UDP & TCP as suggested by SIPgate and assigned it to my device.

Phone works fine for outbound calls but no inbound calls reach the device.

I have logged in as SuperUser as suggested in some other postings and seen the option of
Assign the public IP address of a connection to a device
which I tried but a warning come up advising that I will need to release the current private IP address of the device and then renew the ip address of the device to acquire the public address. None of which I am sure how to do...!
Referring to the CLI manual has not really made it much clearer.

This setup worked using my previous DrayTek Vigor with the device on a static IP in the DMZ, but as I have seen a big speed increase with the new O2 wireless box II I am keen to stay with it if I can.

Can anybody offer any advice...?

Thanks Aussie :smileyindifferent:
Please use plain text.
Level 2: Apprentice
etlpkby
Posts: 23
Registered: ‎22-04-2008

O2 Wireless box II with VoIP

The fact that 'outbound connections are ok and inbound's are denied' would indicate it's a firewall issue on the O2 router. What ports need to be open?

The problem is the O2 router has been 'dumbed down' for noddies to handle it :womanindifferent:

I suspect your application might use ports that are currently not configurable via the O2 router firmware and your only option will be to purchase another ADSL2+ router that has full control over all ports for you to configure inbound UDP and/or TCP connections to your class C (192.168.x.x) IP range on your internal lan.

This will be unsupported by O2 but might be your best bet.
Please use plain text.
Level 1: Joiner
Aussie
Posts: 2
Registered: ‎30-04-2008

Changed Router now all OK

I have been advised by SIPgate that other customers have reported that the ST585 does not work with SIP traffic due to some funny things it does with port numbers!

I have moved to my Draytek and all is now working. Speed is good at about 3.5MB.

Thanks to all who offered advice

Aussie

Thread Closed.
Please use plain text.
Level 2: Apprentice
aidan_whitehous
Posts: 7
Registered: ‎02-07-2008

O2 Wireless box II with VoIP

I take it you were using STUN on the Grandstream?

Alternatively, some of the Speedtouch boxes have VoIP built in but disabled. You can enable it with SuperUser access, but no good for more than one VSP.
Please use plain text.
Level 1: Joiner
NiKita
Posts: 1
Registered: ‎17-01-2009

* SOLVED *

Apparently the ST585 (the o2 Wireless box II) has preconfigured option for SIP which needs to be disabled:
You will need to telnet the device (usually telnet 192.168.1.254). On windows you will need to open a command prompt for that (Start --> All Programs --> Accessories --> Command Prompt)

and then type:

:connection unbind application=SIP port=5060

and then type:

:saveall

Did work for me. I can now get incoming calls.
Please use plain text.
Level 3: Ponderer
benji606
Posts: 205
Registered: ‎24-10-2008

SIPGATE

Reference the point about setting up the stun facility on the Grandstream ATAs, I currently have disabled it. Although it did not make any difference whether it was in or out when using O2's network, it did stop the ATAs working when I use them on the Virgin cable broadband. Since I have access to my own O2 broadband or my son's Virgin broadband ( as a back up ) I left the stun 10000 setting out permanently for simplicity....
Please use plain text.
Level 3: Ponderer
DonDino2
Posts: 337
Registered: ‎30-09-2008

O2 Wireless box II with VoIP

I used to have a Grandstream with a Netgear router and had many many problems with it - then I switched to a Linksys PAP2 for my SIP/VoIP telephones and no problems since.

I recently hooked up my PAP2 to my new O2 Wireless Box II and it works just fine, no need for port forwarding or any other setting on the O2 box. My suggestion is to avoid Grandstream adapters altogether.
Please use plain text.
Level 1: Joiner
usman_gh
Posts: 1
Registered: ‎14-03-2009

Telnet not allowed

I have ST585 V7 router from O2 and as you mentioned i need to telnet and enter the information and then saveall it's not letting me login. Upon entering the login and password, it says telnet not allowed from LAN.

Can any one help me in this regard. I desperatel want to make SIP work on my systems.

Thanks
usman ghani
Please use plain text.
Level 1: Joiner
1z4all
Posts: 1
Registered: ‎29-03-2009

O2 Wireless box II with VoIP

1. Connect as super user to the box:
http://192.168.1.254/cgi/b/dsl/dt/?ce=1&be=0&l0=1&l1=0 User = SuperUser password = O2Br0ad64nd

2. Telnet to box and remove VOIP mapping: (For some reason this did not work when I first tried it without the previous step :womanindifferent:)
telnet 192.168.1.254
User = SuperUser password = O2Br0ad64nd
:connection unbind application=SIP port=5060
:saveall

3. Add Sipgate port forwarding (Games and application sharing)
Protocol Port Range Translate To ... Trigger Protocol Trigger Port
UDP 5060 - 5060 5060 - 5060 - -
UDP 10000 - 10000 10000 - 10000 - -
TCP 3478 - 3478 3478 - 3478 - -
UDP 3478 - 3478 3478 - 3478 - -
TCP 5060 - 5060 5060 - 5060 - -
UDP 5000 - 5010 5000 - 5010 - -
UDP 8000 - 8020 8000 - 8020 - -

4. Assign Sipgate port forwarding to GrandStream adapter:
Game or Application Device Log
Sipgate Unknown-00-00-5e-00-01-0a Off
Obviously the Unknown-00-00-5e-00-01-0a identifier will be different for each device.

It finally works :smileyvery-happy:
Please use plain text.
Level 1: Joiner
dragonuk
Posts: 2
Registered: ‎10-07-2008

SIP / VOIP account sign in issues when using O2 wirelessbox

All,

I am currently using a Netgear DG834Gv2 with the O2 broadband connection. If I don't open any ports I am still able to connect to my SIP / VOPI provider using details below. However with the O2wirelessbox II, even if firewall is disabled, I cannot sign in. I have tried with both O2wirelessbox I and II. I have already followed the recommendations in previous posts.

=== SIP Settings ===
Client: X-Lite 4.0
Proxy: s2hkbntel.net
Use Outbound Proxy: yes
Outbound Proxy: s21.hkbntel.net / s22.hkbntel.net port 5060
Global Discovery
STUN: stun.xten.net
Use OB Proxy In Dialog: yes
Use DNS SRV: no
RTP Packet Size: 0.020 (Crucial to enable incoming calls)
*Phone number: 3xxxxxxx
*User ID: 3xxxxxxxhk
Password: yyyyyyyy

Rgds,

Alex
Please use plain text.