O2 Community

Get help, share tips and chat

Android Devices (Samsung, HTC, Sony Ericsson, etc.)

Reply
Level 3: Ponderer
Barneyballbags
Posts: 29
Registered: ‎25-04-2012

HTC One X - Manual APN Settings - Solution Found!

[ Edited ]

Hi everyone, 

 

After a lot of fiddling and a couple of phonecalls to both O2 and HTC, I've FINALLY managed to get mobile data working on my HTC One X. 

 

I recently bought a white One X, which was given to a friend of mine as an upgrade (he's on Vodafone). The handset came unlocked, but had the Vodafone splash screens and a few bits of Vodafone bloatware on it (and also the Vodafone APN settings by default). 

 

In order to be able to mobile data with my O2 sim in the handset, I had to manually enter the APN settings. This was all well and good until I came to select the profile I had created, when I noticed that it wouldn't let me! 

 

I've since found out that the final step in the instructions which I was sent by O2 was actually incorrect. 

 

O2 instruct you to type "Internet + MMS" into the "APN Type" box. This is not recognised, and is the reason why the profile cannot be selected once it has been created and saved. 

 

Here's what I entered. I have been able to select the APN profile which I created, and my mobile data works just fine now. Follow these instructions step-by-step and you should be good to go. I hope it helps. 

 

The instructions are the ones which O2 emailed through to me. I have simply changed the text in step 20. 

 

Here you go:

 

Method 2: Entering an APN Manually

Please ensure that when entering O2 into the settings that the letter O is selected and not a zero.

When entering the following information do not press Save until told to in the instructions.
1. Tap the Applications key 
2. Tap Settings 
3. Tap Mobile network 
4. Tap Access Point Names 
5. Tap the 3 dots on the Top Right of the sceen 
6. Tap New APN 
7. Tap Name then tap the text box and enter O2 Pay Monthly then tap OK 
8. Tap APN then tap the text box and enter wap.o2.co.uk then tap OK 
9. Tap Proxy then tap the text box and enter 193.113.200.195 then tap OK 
10. Tap Port then tap the text box and enter 8080 then tap OK 
11. Tap Username then tap the text box and enter o2wap then tap OK 
12. Tap Password then tap the text box and enter password then tap OK 
13. Skip past Server as this is preset as Not set 
14. Tap MMSC then tap the text box and enter http://mmsc.mms.o2.co.uk:8002 then tap OK 
15. Tap MMS proxy then tap the text box and enter 193.113.200.195 then tap OK 
16. Tap MMS port then tap the text box and enter 8080 then tap OK 
17. Tap MCC then tap the text box and enter 234 then tap OK 
18. Tap MNC then tap the text box and enter 10 then tap OK 
19. Tap Authentication type and tap PAP 
20. Tap APN type and type * 
21. Press the 3 Dots on the Top Right of the screen 
22. Tap Save 
23. Tap the circle next to the new profile so a green dot appears in it 
24. Press the Back key four times to return to the main menu.

Please use plain text.
Level 1: Joiner
bristevenson
Posts: 1
Registered: ‎01-05-2012

Re: HTC One X - Manual APN Settings - Solution Found!

Good work man, just put new rom on my one x, this got my data and mms up and running again.

Many thanks.
Please use plain text.
Level 1: Joiner
Michealtbh
Posts: 5
Registered: ‎10-06-2012

Re: HTC One X - Manual APN Settings - Solution Found!

I don't know why o2 won't just push the settings directly to some handsets. I could get the settings pushed to my Xperia Play, but my Sensation is a no go. I guarantee if they used the same method on the Sensation as they did on the Play it would work, likewise for the HOX. O2 seem intent on annoying customers, I can't wait til my contract is up.

Please use plain text.
Level 1: Joiner
omar
Posts: 3
Registered: ‎08-06-2012

Re: HTC One X - Manual APN Settings - Solution Found!

Hi I was wondering if you could help me, I have had a similar problem but with the HTC one s, I tried what you suggested but I still cant seem to select the new setting so a green dot appears. I followed everything exactly and I just cant seem to figure out what is going on!

 

Here is a screenshot, of the new - unselectable setting.

 

Screenshot_2012-06-11-12-38-14.png

 

 

Any help is greatly appreciated :smileyhappy:

Please use plain text.
Level 1: Joiner
Michealtbh
Posts: 5
Registered: ‎10-06-2012

Re: HTC One X - Manual APN Settings - Solution Found!

Try setting the apn type to "default,supl,mms". I had to figure that out myself, the settings o2 advised me to use wouldn't work without it. Seriously, do their tech dept not test these things?
Please use plain text.
Level 1: Joiner
omar
Posts: 3
Registered: ‎08-06-2012

Re: HTC One X - Manual APN Settings - Solution Found!

This works perfect! Thanks very much,

 

I agree poor on O2's part, I dont think I have ever had to mess around with settings so much.

Please use plain text.
Level 1: Joiner
RainbowAbz
Posts: 1
Registered: ‎27-06-2012

Re: HTC One X - Manual APN Settings - Solution Found!

You forgot to mention that the phone must then be rebooted for settings to take effect

However this has not worked for me! I am able to select the new setting now but I still have not data connection
Please use plain text.
Level 1: Joiner
Captain_Bridude
Posts: 1
Registered: ‎08-07-2012

Re: HTC One X - Manual APN Settings - Solution Found!

Thanks for that Barneyballbags - a REALLY helpful guide. Worked first time!
Please use plain text.
Level 1: Joiner
RWinckworth
Posts: 1
Registered: ‎17-07-2012

Re: HTC One X - Manual APN Settings - Solution Found!

Genius! Thanks for this. Just bought One X yesterday and was wondering what to do.
Please use plain text.
Level 1: Joiner
rob1
Posts: 1
Registered: ‎19-07-2012

Re: HTC One X - Manual APN Settings - Solution Found!

Thank you for that! o2 send me those wrong steps today. getting me to wonder if they ever check their service... really bad on their part.
Please use plain text.